summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/cdb/cdb-0.75-r4.ebuild')
-rw-r--r--dev-db/cdb/cdb-0.75-r4.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-db/cdb/cdb-0.75-r4.ebuild b/dev-db/cdb/cdb-0.75-r4.ebuild
index c0f6618e6d3e..6f6e1be87205 100644
--- a/dev-db/cdb/cdb-0.75-r4.ebuild
+++ b/dev-db/cdb/cdb-0.75-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="8"
inherit toolchain-funcs
@@ -12,15 +12,17 @@ SRC_URI="https://cr.yp.to/${PN}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
-DEPEND="!dev-db/tinycdb"
-RDEPEND="${DEPEND}"
+RDEPEND="!dev-db/tinycdb"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-errno.patch
"${FILESDIR}"/${PN}-inline.patch
"${FILESDIR}"/${PN}-stdint.patch
)
+DOCS=( CHANGES README TODO VERSION )
src_prepare() {
default
@@ -33,26 +35,25 @@ src_prepare() {
}
src_configure() {
- echo "$(tc-getCC) ${CFLAGS} -fPIC" > conf-cc || die
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
- echo "${EPREFIX}/usr" > conf-home || die
+ echo "$(tc-getCC) ${CFLAGS} -fPIC" >conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" >conf-ld || die
+ echo "${EPREFIX}/usr" >conf-home || die
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest
+ dobin ${PN}{dump,get,make{,-12,-sv},stats,test}
# ok so ... first off, some automakes fail at finding
# cdb.a, so install that now
dolib.a *.a
-
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a
+ dosym ${PN}.a /usr/$(get_libdir)/lib${PN}.a
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
- insinto /usr/include/cdb
- doins cdb*.h buffer.h alloc.h uint32.h
+ insinto /usr/include/${PN}
+ doins ${PN}*.h {alloc,buffer,uint32}.h
- dodoc CHANGES FILES README SYSDEPS TODO VERSION
+ einstalldocs
}