summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/gqlplus/gqlplus-1.16.ebuild')
-rw-r--r--dev-db/gqlplus/gqlplus-1.16.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-db/gqlplus/gqlplus-1.16.ebuild b/dev-db/gqlplus/gqlplus-1.16.ebuild
index a3aa8f209869..b21f38c84694 100644
--- a/dev-db/gqlplus/gqlplus-1.16.ebuild
+++ b/dev-db/gqlplus/gqlplus-1.16.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools
DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
-HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
+HOMEPAGE="https://gitlab.com/jessp011/gqlplus"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -17,12 +17,17 @@ IUSE=""
DEPEND="sys-libs/readline:*"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-ncurses-tinfo.patch )
+
src_prepare() {
+ default
+
# don't use packaged readline and old version containing it
rm -Rf readline gqlplus-1.15
# maintainer can't seem to get versioning right
sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
+
eautoreconf
}