summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-2.5.2.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-2.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-2.5.2.ebuild b/dev-db/mysqltuner/mysqltuner-2.5.2.ebuild
new file mode 100644
index 000000000000..7ce503589cae
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-2.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="MySQLTuner-perl"
+
+DESCRIPTION="Makes recommendations for increased performance and stability for MySQL"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.5.2-missing-shebang.patch" )
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ newbin mysqltuner.pl mysqltuner
+ dodoc {CONTRIBUTING,INTERNALS,USAGE}.md
+ einstalldocs
+
+ # Passwords and vulnerabilities are meant to be fed to the script uncompressed.
+ dodoc basic_passwords.txt vulnerabilities.csv
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}