summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysqltuner')
-rw-r--r--dev-db/mysqltuner/Manifest1
-rw-r--r--dev-db/mysqltuner/mysqltuner-2.2.12.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/Manifest b/dev-db/mysqltuner/Manifest
index af045b5c99db..58c645e09a54 100644
--- a/dev-db/mysqltuner/Manifest
+++ b/dev-db/mysqltuner/Manifest
@@ -1 +1,2 @@
DIST mysqltuner-1.9.9.tar.gz 225048 BLAKE2B 5c22ecbe3ab8ab2ad8712c6cbdfbc6bb182e6211d7894c2dc10c68b5b31f74f7512747c983844ba6ce9e12e422f510e4e68a18e85e29f443424e4dfa7055e1f7 SHA512 9373fcbcf514a989126b100739a87d711b4c2081e2608b4576d0ab88590ffd85fae57f1587e1d9f44cf0d89baa92eeb9115db2c4c6c491b701e965de7a549fa0
+DIST mysqltuner-2.2.12.tar.gz 5130342 BLAKE2B 9a62f634a18f94d8f844aa93a0c7b2595bf29c9888005c89bdf8c0acb7376548dd745e46b2c0d67bb2ab5b79acd4ce19f6fd99b525bf8794e92b7713020128ac SHA512 84352c3bce74a7288ea1ac5a7c2e513ff0cd35656df5280bedf8738eb4b90ad0cdf039510d874947080720f56f0f947a964cf5152788a7566616e012a5f94c85
diff --git a/dev-db/mysqltuner/mysqltuner-2.2.12.ebuild b/dev-db/mysqltuner/mysqltuner-2.2.12.ebuild
new file mode 100644
index 000000000000..266444479b86
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-2.2.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="MySQLTuner-perl"
+
+DESCRIPTION="Makes recommendations for increased performance and stability for MySQL"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ newbin mysqltuner.pl mysqltuner
+ dodoc {CONTRIBUTING,INTERNALS,USAGE}.md
+ einstalldocs
+
+ # Passwords and vulnerabilities are meant to be fed to the script uncompressed.
+ dodoc basic_passwords.txt vulnerabilities.csv
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}