summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/ocp')
-rw-r--r--dev-db/ocp/ocp-0.3.ebuild5
-rw-r--r--dev-db/ocp/ocp-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-db/ocp/ocp-0.3.ebuild b/dev-db/ocp/ocp-0.3.ebuild
index 47e7110d55b1..baeb53e6decb 100644
--- a/dev-db/ocp/ocp-0.3.ebuild
+++ b/dev-db/ocp/ocp-0.3.ebuild
@@ -6,14 +6,15 @@ EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
+inherit toolchain-funcs
+
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools toolchain-funcs
+ inherit autotools git-r3
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- inherit toolchain-funcs
fi
LICENSE="GPL-2"
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
index 47e7110d55b1..baeb53e6decb 100644
--- a/dev-db/ocp/ocp-9999.ebuild
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -6,14 +6,15 @@ EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
+inherit toolchain-funcs
+
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools toolchain-funcs
+ inherit autotools git-r3
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- inherit toolchain-funcs
fi
LICENSE="GPL-2"