summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pg_top/pg_top-4.0.0-r1.ebuild')
-rw-r--r--dev-db/pg_top/pg_top-4.0.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/pg_top/pg_top-4.0.0-r1.ebuild b/dev-db/pg_top/pg_top-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..bb38e3056d70
--- /dev/null
+++ b/dev-db/pg_top/pg_top-4.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="'top' for PostgreSQL"
+HOMEPAGE="https://pg_top.gitlab.io/"
+SRC_URI="https://pg_top.gitlab.io/source/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}"
+
+DOCS=( HISTORY.rst README.rst TODO Y2K )
+
+src_prepare() {
+ sed 's/set(CMAKE_C_FLAGS "-Wall")//' -i CMakeLists.txt || die
+ cmake_src_prepare
+}