summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgagent')
-rw-r--r--dev-db/pgagent/Manifest2
-rw-r--r--dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch33
-rw-r--r--dev-db/pgagent/pgagent-4.2.1.ebuild (renamed from dev-db/pgagent/pgagent-4.0.0-r1.ebuild)29
3 files changed, 12 insertions, 52 deletions
diff --git a/dev-db/pgagent/Manifest b/dev-db/pgagent/Manifest
index b88d3cf25a9b..9e64e509a8e8 100644
--- a/dev-db/pgagent/Manifest
+++ b/dev-db/pgagent/Manifest
@@ -1 +1 @@
-DIST pgAgent-4.0.0-Source.tar.gz 63561 BLAKE2B 1731e748a6a5e76cd8b177162eb5b82ae633d1b507739e3193a8857a0eee0fe775fdaadb871eb5d708c0f7e80558680b5d7d246f4cb5d2bc1c10955bdf9cc09e SHA512 df2d6f5817d83d4cf60f0f1106718225870bcfd2f5b882765e5fd459e1614208225f90b29de492bec5284f3727f3d4be9f724b92ef503fea08029fab22a8fbb4
+DIST pgAgent-4.2.1-Source.tar.gz 65583 BLAKE2B ee75803475dfbb751f1a81da5c3a6bec82aee80e9ce7d0413f94395069b5c0cbb6ff8770083078ce0e3a571a4c1b6d2e6adf6af8f0bfa9e8adfc862fff38d0d3 SHA512 778ca020ec23b3d042760cdcf84d3c2da8da48c8a648a9999812c2e79edfcc8912ab23cc1a1c29f379d6a56960cdd876164397b8fe6b21dd386a917a80eaa71c
diff --git a/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch b/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch
deleted file mode 100644
index 95f8e998f58f..000000000000
--- a/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 5b79460bdda286ca988b39e93e446176e8a781d1 Mon Sep 17 00:00:00 2001
-From: Neel Patel <neel.patel@enterprisedb.com>
-Date: Fri, 20 Jul 2018 13:35:35 +0100
-Subject: [PATCH] Link with pthreads on non-Windows and non-macOS platforms.
-
-Patch based on feedback and initial work by Christoph Berg.
----
- CMakeLists.txt | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1be24da..6f1eaa0 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -134,9 +134,15 @@ IF(WIN32)
- ENDIF(WIN32)
-
- ADD_EXECUTABLE(pgagent ${_srcs})
-+IF(UNIX AND NOT APPLE)
-+TARGET_LINK_LIBRARIES(
-+ pgagent ${PG_LIBRARIES} ${Boost_LIBRARIES} -pthread
-+)
-+ELSE()
- TARGET_LINK_LIBRARIES(
- pgagent ${PG_LIBRARIES} ${Boost_LIBRARIES}
- )
-+ENDIF()
-
- # Installation
- IF (WIN32)
---
-2.24.1
-
diff --git a/dev-db/pgagent/pgagent-4.0.0-r1.ebuild b/dev-db/pgagent/pgagent-4.2.1.ebuild
index 50120fe2593b..e6e675fbee11 100644
--- a/dev-db/pgagent/pgagent-4.0.0-r1.ebuild
+++ b/dev-db/pgagent/pgagent-4.2.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils user
+inherit cmake
MY_PN=${PN/a/A}
@@ -17,39 +17,32 @@ SRC_URI="https://ftp.postgresql.org/pub/pgadmin/${PN}/${MY_PN}-${PV}-Source.tar.
LICENSE="POSTGRESQL GPL-2"
SLOT="0"
-RDEPEND="dev-db/postgresql:*
- dev-libs/boost
+RDEPEND="
+ acct-user/pgagent
+ dev-db/postgresql:*
+ dev-libs/boost
"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}-Source"
-PATCHES=( "${FILESDIR}"/pgagent-4.0.0-pthreads-linking.patch )
-
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "s:share):share/${P}):" \
-i CMakeLists.txt || die "failed to patch CMakeLists.txt"
}
src_configure() {
- mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE"
- )
- cmake-utils_src_configure
+ local mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE" )
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/pgagent.initd-r1" "${PN}"
newconfd "${FILESDIR}/pgagent.confd" "${PN}"
rm "${ED}"/usr/{LICENSE,README} || die "failed to remove useless docs"
}
-
-pkg_preinst() {
- # This user needs a real shell, and the daemon will use the
- # ~/.pgpass file from its home directory.
- enewuser pgagent -1 /bin/bash /home/pgagent
-}