summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgcli/pgcli-3.3.1-r2.ebuild')
-rw-r--r--dev-db/pgcli/pgcli-3.3.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/pgcli/pgcli-3.3.1-r2.ebuild b/dev-db/pgcli/pgcli-3.3.1-r2.ebuild
new file mode 100644
index 000000000000..65af71f16b94
--- /dev/null
+++ b/dev-db/pgcli/pgcli-3.3.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/pgcli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/cli_helpers-2.2.1[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pendulum[${PYTHON_USEDEP}]
+ dev-python/pgspecial[${PYTHON_USEDEP}]
+ dev-python/prompt-toolkit[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/sqlparse[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-db/postgresql
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest