summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgcli')
-rw-r--r--dev-db/pgcli/Manifest1
-rw-r--r--dev-db/pgcli/metadata.xml15
-rw-r--r--dev-db/pgcli/pgcli-2.0.2.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-db/pgcli/Manifest b/dev-db/pgcli/Manifest
new file mode 100644
index 000000000000..2e35d371fc67
--- /dev/null
+++ b/dev-db/pgcli/Manifest
@@ -0,0 +1 @@
+DIST pgcli-2.0.2.tar.gz 432325 BLAKE2B 5cbe2be05910d9bfa64e7ac908d636a39ed11f994e0e81cd06afce97510e02be335837b2587653df716beee0d30076f07489ac8e4fb05fbc579bceee8636a470 SHA512 5681effcb36101ce408f7c4dcc881984686d63a6e593bd4f5c2bb3b2d870362c787094895ece027a3ba27d3a4524498b27082da0f25b1b77f23e54b2df6c0501
diff --git a/dev-db/pgcli/metadata.xml b/dev-db/pgcli/metadata.xml
new file mode 100644
index 000000000000..6f3a86a539c9
--- /dev/null
+++ b/dev-db/pgcli/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>linder.gabriel@gmail.com</email>
+ <name>Gabriel Linder</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbcli/pgcli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pgcli/pgcli-2.0.2.ebuild b/dev-db/pgcli/pgcli-2.0.2.ebuild
new file mode 100644
index 000000000000..e8b5fdac5664
--- /dev/null
+++ b/dev-db/pgcli/pgcli-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/prompt_toolkit-2.1.0[${PYTHON_USEDEP}]
+ <dev-python/psycopg-2.8[${PYTHON_USEDEP}]
+ <dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/humanize-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/keyring-12.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pgspecial-1.11.5[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"