summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index e90d6a96bf13..767646540580 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
PLOCALES="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN
zh_TW"
PLOCALES="af cs de en es fa fr hr hu it ko nb pl pt-BR ro ru sk sl sv tr zh-CN
zh-TW"
inherit flag-o-matic git-r3 linux-info multilib pam prefix python-single-r1 \
- systemd user versionator
+ systemd user
KEYWORDS=""
@@ -23,8 +23,9 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="kerberos kernel_linux ldap libressl llvm nls pam perl python +readline
- selinux systemd ssl static-libs tcl threads uuid xml zlib"
+IUSE="debug icu kerberos kernel_linux ldap libressl llvm nls pam perl
+ python +readline selinux systemd ssl static-libs tcl threads uuid
+ xml zlib"
for my_locale in ${PLOCALES}; do
IUSE+=" l10n_${my_locale}"
done
@@ -35,6 +36,7 @@ CDEPEND="
>=app-eselect/eselect-postgresql-2.0
sys-apps/less
virtual/libintl
+icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap )
llvm? (
@@ -178,8 +180,10 @@ src_configure() {
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable !alpha spinlocks) \
+ $(use_enable debug) \
$(use_enable nls nls "'$(my_get_locales)'") \
$(use_enable threads thread-safety) \
+ $(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
$(use_with llvm) \
@@ -208,7 +212,11 @@ src_install() {
insinto /etc/postgresql-${SLOT}
newins src/bin/psql/psqlrc.sample psqlrc
- use static-libs || find "${ED}" -name '*.a' -delete
+ # Don't delete libpg{port,common}.a (Bug #571046). They're always
+ # needed by extensions utilizing PGXS.
+ use static-libs || \
+ find "${ED}" -name '*.a' ! -name libpgport.a ! -name libpgcommon.a \
+ -delete
sed -e "s|@SLOT@|${SLOT}|g" -e "s|@LIBDIR@|$(get_libdir)|g" \
"${FILESDIR}/${PN}.confd-9.3" | newconfd - ${PN}-${SLOT}