summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild')
-rw-r--r--dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..0f4302f052c7
--- /dev/null
+++ b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A collection of CLI tools supporting SpatiaLite"
+HOMEPAGE="https://www.gaia-gis.it/spatialite"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+RDEPEND="
+ dev-db/sqlite:3[extensions(+)]
+ >=dev-db/spatialite-3.0.1[geos,xls]
+ dev-libs/expat
+ dev-libs/libxml2
+ sci-geosciences/readosm
+ sci-libs/geos
+ sci-libs/proj
+ readline? (
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable readline)
+}