summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/sqlite-3.45.1-lto.patch20
-rw-r--r--dev-db/sqlite/sqlite-3.45.1-r1.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.45.1-lto.patch b/dev-db/sqlite/files/sqlite-3.45.1-lto.patch
new file mode 100644
index 000000000000..3f15d1a29265
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.45.1-lto.patch
@@ -0,0 +1,20 @@
+# Bug: https://bugs.gentoo.org/924300
+# Taken from https://sqlite.org/src/info/803481f25020f3c
+--- a/test/fuzzcheck.c
++++ b/test/fuzzcheck.c
+@@ -159,12 +159,12 @@
+ } g;
+
+ /*
+ ** Include the external vt02.c and randomjson.c modules.
+ */
+-extern int sqlite3_vt02_init(sqlite3*,char***,void*);
+-extern int sqlite3_randomjson_init(sqlite3*,char***,void*);
++extern int sqlite3_vt02_init(sqlite3*,char**,const sqlite3_api_routines*);
++extern int sqlite3_randomjson_init(sqlite3*,char**,const sqlite3_api_routines*);
+
+
+ /*
+ ** Print an error message and quit.
+ */
+
diff --git a/dev-db/sqlite/sqlite-3.45.1-r1.ebuild b/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
index ad62f71390b1..20b0d016dc47 100644
--- a/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
@@ -52,6 +52,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-3.45.1-ppc64-ptr.patch
+ "${FILESDIR}"/${P}-lto.patch
)
_fossil_fetch() {