summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlmap')
-rw-r--r--dev-db/sqlmap/Manifest2
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.11.ebuild60
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.12.ebuild60
3 files changed, 0 insertions, 122 deletions
diff --git a/dev-db/sqlmap/Manifest b/dev-db/sqlmap/Manifest
index 317ecb4d03a6..5868bb9c4061 100644
--- a/dev-db/sqlmap/Manifest
+++ b/dev-db/sqlmap/Manifest
@@ -1,4 +1,2 @@
-DIST sqlmap-1.6.11.gh.tar.gz 7206836 BLAKE2B fd55093c873537d8607822d4bf84b6eed47a1a01e89750265c040f70a82faea2141096a611f66c46f025cfe2893cb0401e63034c80be6d736cc25246cd70e3fd SHA512 d773ab5e45e933ed64533e3ede0ec3e25543ecf9489fa72dc57558385ddb7c515e57952022b8c350fbeb347f6e935864e22c2cc51abee81740fd66478349e2ab
-DIST sqlmap-1.6.12.gh.tar.gz 7207020 BLAKE2B 9d26c5a5dce4bd2eb5ab38b307d211fefc27a2fe0784f7d91dade2a1eecabdbeec506eeb8bed4a85993873760bb050a77c16d08f01ecdaad1e82e56dbf17c12e SHA512 297cd31f055ee7ee41244f205e9cf71209a29d71e7002331a0d7eba04a151a238cef5c3c06710af516b86cdb95ae9bb72b63019830004a366008b798aad768aa
DIST sqlmap-1.7.2.gh.tar.gz 7208613 BLAKE2B 69c8f6ba75b884ef13a693857a864df973a7f38f796b3489adea3ef1fbfaf01a2181b0f22af124b8efa22c29d0f988fa3bb1050b33e84aa029bb97a6c2f0e949 SHA512 a26da178ba151d8c34574dee30f4247ec16002b719fbb0ecd56dc074c9806daa81ed0d414421641d98b354663ff1685596c5f276f6e4812dae266dbab84a8286
DIST sqlmap-1.7.gh.tar.gz 7207796 BLAKE2B 5a30cb111b0b6b8c37ff8b9ec37e3724b51b9a41cdd3d75d9665cfc6ceb4c9d11d642714cd327669015309b427184663c0ba248c4158378489bc5e0668a8cb7a SHA512 ca79239eec7b0e72a37de65471787800837b01c9567a8dae617bda5f4dde70c80a0d2e8f38373245bf43cf6feaca19e606dddd482f7c1ca7b18745ca107693f3
diff --git a/dev-db/sqlmap/sqlmap-1.6.11.ebuild b/dev-db/sqlmap/sqlmap-1.6.11.ebuild
deleted file mode 100644
index ad6dac4b9230..000000000000
--- a/dev-db/sqlmap/sqlmap-1.6.11.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit bash-completion-r1 python-single-r1 wrapper
-
-DESCRIPTION="An automatic SQL injection and database takeover tool"
-HOMEPAGE="https://sqlmap.org/"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
-else
- SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-# sqlmap (GPL-2+)
-# ansitrm (BSD)
-# beautifulsoup (BSD)
-# bottle (MIT)
-# chardet (LGPL-2.1+)
-# clientform (BSD)
-# colorama (BSD)
-# fcrypt (BSD-2)
-# identitywaf (MIT)
-# keepalive (LGPL-2.1+)
-# magic (MIT)
-# multipartpost (LGPL-2.1+)
-# ordereddict (MIT)
-# prettyprint (BSD-2)
-# pydes (public-domain)
-# six (MIT)
-# socks (BSD)
-# termcolor (BSD)
-# wininetpton (public-domain)
-LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
-SLOT="0"
-
-RDEPEND="${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=( doc/ README.md )
-
-src_install () {
- einstalldocs
-
- insinto /usr/share/${PN}/
- doins -r *
- python_optimize "${ED}"/usr/share/${PN}
-
- make_wrapper ${PN} \
- "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
-
- newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
-}
diff --git a/dev-db/sqlmap/sqlmap-1.6.12.ebuild b/dev-db/sqlmap/sqlmap-1.6.12.ebuild
deleted file mode 100644
index 550ec7d5d4b0..000000000000
--- a/dev-db/sqlmap/sqlmap-1.6.12.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit bash-completion-r1 python-single-r1 wrapper
-
-DESCRIPTION="An automatic SQL injection and database takeover tool"
-HOMEPAGE="https://sqlmap.org/"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
-else
- SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-# sqlmap (GPL-2+)
-# ansitrm (BSD)
-# beautifulsoup (BSD)
-# bottle (MIT)
-# chardet (LGPL-2.1+)
-# clientform (BSD)
-# colorama (BSD)
-# fcrypt (BSD-2)
-# identitywaf (MIT)
-# keepalive (LGPL-2.1+)
-# magic (MIT)
-# multipartpost (LGPL-2.1+)
-# ordereddict (MIT)
-# prettyprint (BSD-2)
-# pydes (public-domain)
-# six (MIT)
-# socks (BSD)
-# termcolor (BSD)
-# wininetpton (public-domain)
-LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
-SLOT="0"
-
-RDEPEND="${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=( doc/ README.md )
-
-src_install () {
- einstalldocs
-
- insinto /usr/share/${PN}/
- doins -r *
- python_optimize "${ED}"/usr/share/${PN}
-
- make_wrapper ${PN} \
- "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
-
- newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
-}