summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/wxsqlite3/wxsqlite3-3.2.1.ebuild')
-rw-r--r--dev-db/wxsqlite3/wxsqlite3-3.2.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-db/wxsqlite3/wxsqlite3-3.2.1.ebuild b/dev-db/wxsqlite3/wxsqlite3-3.2.1.ebuild
deleted file mode 100644
index af7c5651ae96..000000000000
--- a/dev-db/wxsqlite3/wxsqlite3-3.2.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-WX_GTK_VER="3.0"
-
-inherit eutils multilib wxwidgets
-
-DESCRIPTION="C++ wrapper around the public domain SQLite 3.x database"
-HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
-SRC_URI="mirror://sourceforge/wxcode/${P}.tar.gz"
-
-LICENSE="wxWinLL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND="
- x11-libs/wxGTK:3.0[X,debug=]
- dev-db/sqlite:3"
-RDEPEND="${DEPEND}"
-
-#S="${WORKDIR}/${P%.1}"
-
-src_prepare() {
- local wxdebug
-
- rm -rf sqlite3 || die
- cp configure30 configure || die
- use debug && wxdebug="d"
- sed \
- -e "s:@WXDEBUG@:${wxdebug}:g" \
- -e "s:@WXVERSION@:${WX_GTK_VER}:g" \
- -e "s:@LIBDIR@:$(get_libdir):g" \
- -e "s:@VERSION@:${PV}:g" \
- "${FILESDIR}"/${PN}-3.0.6.1.pc.in > ${PN}.pc || die
-}
-
-src_configure() {
- econf \
- --enable-shared \
- --enable-unicode \
- --with-wx-config="${WX_CONFIG}" \
- --with-wxshared \
- --with-sqlite3-prefix="${PREFIX}/usr"
-}
-
-src_install() {
- default
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${PN}.pc
-
- dodoc Readme.txt
- dohtml -r docs/html/*
- docinto samples
- dodoc -r samples/*
-}