summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysqltuner/Manifest1
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.8.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/Manifest b/dev-db/mysqltuner/Manifest
index 4558c232abf5..b294383a2e78 100644
--- a/dev-db/mysqltuner/Manifest
+++ b/dev-db/mysqltuner/Manifest
@@ -1 +1,2 @@
DIST mysqltuner-1.7.21.tar.gz 223961 BLAKE2B 1307afc2a73b40330817fe0c0b834a537b14caed1125acbdc5a03e98787321ffbbfb84ba0a2077adb0fa49c0e2df947dc0062d2218866c689fbfd903776f7fbd SHA512 2b5d8a7cc3f0ebe3a481cd77e395ead37ec037f0a9b9649bbf450215bc83f4049a297d86b171c7e2e7d51b3fbe381069310f13d3b8152f5a90e05a9efbabd4dc
+DIST mysqltuner-1.8.3.tar.gz 254525 BLAKE2B 7fa1fe24ab454aa15a03e62410e08988a4a0d3ac9b1e4df0219a67bffa4d6113d8c89d6f93f8e6d08a35ecc4bdbf5c0148d8e53138f05a5c22899ecca98b3614 SHA512 965ad0204cb449aa113bf1880a91468d48467c84e7d42ac8f12e7ee4035e49dc7cb191d2b11b6e5b084a60c3857e92ac4d1bef63f688538f3468fda32304a702
diff --git a/dev-db/mysqltuner/mysqltuner-1.8.3.ebuild b/dev-db/mysqltuner/mysqltuner-1.8.3.ebuild
new file mode 100644
index 000000000000..77500787a893
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.8.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="MySQLTuner-perl"
+
+DESCRIPTION="Makes recommendations for increased performance and stability for MySQL"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ newbin mysqltuner.pl mysqltuner
+ dodoc {CONTRIBUTING,INTERNALS,USAGE}.md
+ einstalldocs
+
+ # Passwords and vulnerabilities are meant to be fed to the script uncompressed.
+ dodoc basic_passwords.txt vulnerabilities.csv
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}