summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlmap/Manifest1
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.10.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/sqlmap/Manifest b/dev-db/sqlmap/Manifest
index 0d8c416b0458..d4306188d124 100644
--- a/dev-db/sqlmap/Manifest
+++ b/dev-db/sqlmap/Manifest
@@ -1,2 +1,3 @@
+DIST sqlmap-1.6.10.gh.tar.gz 7206382 BLAKE2B 2beaf7d49599f7e8072d0725bc58d00c4fd1096316080013f0892cd1c25a2b05c5682191bc87aa9210b21393142aafb43c8ecb5855699716f287e01be2b6ffff SHA512 a2d08f62a4e78fee6761a17b45913dc8794ec07ae466042f41bb5ba524221d670ae6c8f0cde92590d45f0919cb52c1fb98b83e58099eba1b0fd8e833d68d12ad
DIST sqlmap-1.6.8.gh.tar.gz 7205751 BLAKE2B 49fddc4b7c62c9baa5d6732bb9150bd2b3e48a671f9a3601ffc0821d5784fa02fbba37bc057ecd43888c2678ae477cca46b279e59b8a672310836218700df241 SHA512 e8849bb727ca84540fa9e44e580470aa6d853f7fcd1bddc2a51a5e4366a7eceedde80b3bd334f16753d5390ee0ac15fbd81551e79ada817bb11b6964dd439c9b
DIST sqlmap-1.6.9.gh.tar.gz 7205911 BLAKE2B 7da1ae0201d0194c67bfc02b5f2e4e0319eb5820129da7c2708ec8012a7e9474a798767331c541ecea4e078a21d7117a2416ce7e2d135151512019e0ddc543d2 SHA512 ae1b78a75b591162898aaf273d476bd0d4a414820169c463e0694105e774c487bc546c6eb134d8200a51ddb152f5204134032e60f51484ba1a15af7040211d4d
diff --git a/dev-db/sqlmap/sqlmap-1.6.10.ebuild b/dev-db/sqlmap/sqlmap-1.6.10.ebuild
new file mode 100644
index 000000000000..6b74d8864800
--- /dev/null
+++ b/dev-db/sqlmap/sqlmap-1.6.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 python-single-r1 wrapper
+
+DESCRIPTION="An automatic SQL injection and database takeover tool"
+HOMEPAGE="https://sqlmap.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
+else
+ SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# sqlmap (GPL-2+)
+# ansitrm (BSD)
+# beautifulsoup (BSD)
+# bottle (MIT)
+# chardet (LGPL-2.1+)
+# clientform (BSD)
+# colorama (BSD)
+# fcrypt (BSD-2)
+# identitywaf (MIT)
+# keepalive (LGPL-2.1+)
+# magic (MIT)
+# multipartpost (LGPL-2.1+)
+# ordereddict (MIT)
+# prettyprint (BSD-2)
+# pydes (public-domain)
+# six (MIT)
+# socks (BSD)
+# termcolor (BSD)
+# wininetpton (public-domain)
+LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( doc/ README.md )
+
+src_install () {
+ einstalldocs
+
+ insinto /usr/share/${PN}/
+ doins -r *
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
+
+ newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
+}