summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild')
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild
index 2ad38f3dd580..dd8eaae46b9a 100644
--- a/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild
@@ -7,7 +7,12 @@ MAJOR="$(ver_cut 1)"
DOTNET_PKG_COMPAT=8.0
NUGETS="
+fabulous.ast@0.7.0
+fantomas.core@6.3.0-alpha-003
+fantomas.fcs@6.3.0-alpha-003
+fsharp.core@6.0.1
fsharp.core@8.0.100
+fsharp.core@8.0.101
fsharp.data.csv.core@6.3.0
fsharp.data.html.core@6.3.0
fsharp.data.http@6.3.0
@@ -18,7 +23,17 @@ fsharp.data.xml.core@6.3.0
fsharp.data@6.3.0
libgit2sharp.nativebinaries@2.0.321
libgit2sharp@0.29.0
+microsoft.netcore.platforms@1.1.1
+microsoft.netcore.targets@1.1.3
+org.xgqt.simplelog@0.0.0
+runtime.any.system.runtime@4.3.0
+runtime.native.system@4.3.0
+runtime.unix.system.private.uri@4.3.0
system.commandline@2.0.0-beta4.22272.1
+system.diagnostics.diagnosticsource@7.0.0
+system.memory@4.5.5
+system.private.uri@4.3.0
+system.runtime@4.3.1
"
inherit dotnet-pkg
@@ -57,11 +72,8 @@ src_unpack() {
src_prepare() {
dotnet-pkg_src_prepare
- local tool_project
- while read -r tool_project ; do
- DOTNET_PKG_PROJECTS+=( $(find "${tool_project}/src" -name "*proj") )
- DOTNET_TOOLS+=( "${tool_project}" )
- done < <(cat ./gdmt-tools.txt)
+ DOTNET_PKG_PROJECTS=( $(find . -name "Gdmt.*proj") )
+ DOTNET_TOOLS=( $(cat ./gdmt-tools.txt) )
einfo "Will build following DOTNET_PKG_PROJECTS: ${DOTNET_PKG_PROJECTS[@]}"
einfo "Will build following DOTNET_TOOLS: ${DOTNET_TOOLS[@]}"