summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gentoo-dotnet-maintainer-tools')
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest1
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.2.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest b/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest
index 387f82529b11..16b6116607e5 100644
--- a/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest
@@ -9,6 +9,7 @@ DIST fsharp.data.worldbank.core.6.3.0.nupkg 56347 BLAKE2B 5dc760236e85ef1755a2e1
DIST fsharp.data.xml.core.6.3.0.nupkg 64478 BLAKE2B eaeeaf5d0f31a9a7694bd02732e748be62f717e5cdda2f9f02370c0b394dc0dd47e75058887d90c44ace7e9117393667f3a8a31b00035903b9ed0aab7b7cbb43 SHA512 2ceb6130b8c3fe5f18a3a732876508c00c27468b48cff740143754bf894b8827bf3e48d905a4956201d95d328f64106950c4b18aed77a09ccc23db0ab63cdbb8
DIST gentoo-dotnet-maintainer-tools-2.0.1.tar.bz2 25470 BLAKE2B 2a972ab7a01997ea3a41ace118f39996f1a232a6b7d66ff5b5c9db9763960e2d188116e289e0e8e0e045350e80e9de706e899db928a1b00d0a0b1e4c58534301 SHA512 84454ef54c1228b21fa6a34c895202dfb4509314c011503c6ce4ffca941f308383d8edbbf099ef5d182635e6bd4346f0c25e9ed9a2ba817350e0485f53a52f97
DIST gentoo-dotnet-maintainer-tools-2.1.0.tar.bz2 29461 BLAKE2B f66301ed2b010557755b57216aad5d7384af757ca5632750870c81ceb4ae1359fb2191589dde125725d6e0e7aa199b83886317d743325f136602a7dbbc0620a8 SHA512 69a8237b98955e2977be543bff32f170c3c1c315307decb7911e6e96b080aeba80c24b0d7e3a5453f11198fc85aa46a23a23f94b442085259e49e122fd32f71c
+DIST gentoo-dotnet-maintainer-tools-2.2.0.tar.bz2 32113 BLAKE2B 925e0beb239905d14b7abb293ecb455d386792cf169df16f08527d9bda5298132f2b1652d22ef767c5287caa1c7c4dcf39233be887ad5c6728f4b4b5bb162f74 SHA512 3a4e46c18f9d39cffd9545690ab8456f1e73b00e3294b615f6ee8b74ff5de458e4dd2a5b8fa33bed886c74cfc3934e4901ff1fee89e58436e626c9eb81791775
DIST libgit2sharp.0.29.0.nupkg 720966 BLAKE2B 7fdb41e1654d2f572aabbe8141e8d39205437dc2e3bcd0f1dae3514b8c3bc2939fd418b44fb98f73d05b0a38b237b16bdc955343b0d05763a2db474477bf2e1f SHA512 add84f8c68c11e46247370cd3b506627326f26d1c9c5e23643e167875ffdf21ec90a5bb915d043e91a76a2820798db6ec13cdcb613a92b75d732a2a901b8b8a2
DIST libgit2sharp.nativebinaries.2.0.321.nupkg 7966938 BLAKE2B d76dfae54215e463c3fc7ed652b93cfe8cf6bd9bd654eb70c443b226dcf9fbf5642949b5278b09bfa2abdad4707c9a22813a61098eef07af6c461f0e14237d0c SHA512 3b975be9c20bf4c1c637fefa1728443e5729a14c874b93818af0f177650d5e904bb8d09bb8fb9c490ee37391de96ddbabcda05fc4de519a990ceb79831b31d96
DIST system.commandline.2.0.0-beta4.22272.1.nupkg 616636 BLAKE2B 5252560598c4cd67348520cea086c37b4151b984a61238de1984838975340247b16050113422b1765931bdfc1dee38e226789b6427e56ab7c3a36bf07d0bcc20 SHA512 979a7e66ba29e17bc5bec42e926ed15362e23ae403e498c955e09dffc4d3baa14777a06f95e25d591fc9757a0eaa18deb9e4662a1ca1663fa300f509a4a0383c
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.2.0.ebuild b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.2.0.ebuild
new file mode 100644
index 000000000000..2ad38f3dd580
--- /dev/null
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR="$(ver_cut 1)"
+
+DOTNET_PKG_COMPAT=8.0
+NUGETS="
+fsharp.core@8.0.100
+fsharp.data.csv.core@6.3.0
+fsharp.data.html.core@6.3.0
+fsharp.data.http@6.3.0
+fsharp.data.json.core@6.3.0
+fsharp.data.runtime.utilities@6.3.0
+fsharp.data.worldbank.core@6.3.0
+fsharp.data.xml.core@6.3.0
+fsharp.data@6.3.0
+libgit2sharp.nativebinaries@2.0.321
+libgit2sharp@0.29.0
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION="Gentoo tools for .NET packages maintenance"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Dotnet
+ https://gitlab.gentoo.org/dotnet/gentoo-dotnet-maintainer-tools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+S="${WORKDIR}/${P}/Source/v${MAJOR}"
+
+LICENSE="GPL-2+"
+SLOT="0/${MAJOR}"
+
+DOTNET_PKG_PROJECTS=()
+DOTNET_TOOLS=()
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_prepare() {
+ dotnet-pkg_src_prepare
+
+ local tool_project
+ while read -r tool_project ; do
+ DOTNET_PKG_PROJECTS+=( $(find "${tool_project}/src" -name "*proj") )
+ DOTNET_TOOLS+=( "${tool_project}" )
+ done < <(cat ./gdmt-tools.txt)
+
+ einfo "Will build following DOTNET_PKG_PROJECTS: ${DOTNET_PKG_PROJECTS[@]}"
+ einfo "Will build following DOTNET_TOOLS: ${DOTNET_TOOLS[@]}"
+}
+
+src_install() {
+ dotnet-pkg_src_install
+
+ local tool_exe
+ for tool_exe in "${DOTNET_TOOLS[@]}" ; do
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/${tool_exe}"
+ done
+}