summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild')
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..d49ad2206bc7
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd xdg-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ xdg_desktop_database_update
+}