summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/xsp/files')
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd83
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server.confd34
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server.initd81
-rw-r--r--dev-dotnet/xsp/files/2.2/xsp.confd12
-rw-r--r--dev-dotnet/xsp/files/2.2/xsp.initd38
-rw-r--r--dev-dotnet/xsp/files/aclocal-fix.patch13
-rw-r--r--dev-dotnet/xsp/files/xsp-2.10.2-endrequest.patch35
7 files changed, 0 insertions, 296 deletions
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd b/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
deleted file mode 100644
index 6ce6a60bcec2..000000000000
--- a/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: mod-mono-server-r1.initd,v 1.1 2012/01/22 12:54:29 pacho Exp $
-
-depend() {
- use net
- after dotnet
-}
-
-start() {
- [ -z "$MonoServerRootDir" ] && \
- MonoServerRootDir="/usr/lib/xsp/test"
- [ -z "$MonoApplications" ] && \
- MonoApplications="/mono:/usr/lib/xsp/test,/:."
- [ -z "$UnixSocketFileName" ] && \
- UnixSocketFileName="/tmp/mod_mono_server"
- [ -z "$MonoServerAddress" ] && \
- MonoServerAddress=127.0.0.1
- [ -z "$MonoServerPort" ] && \
- MonoServerPort=8080
- [ -z "$MonoServerVersion" ] && \
- MonoServerVersion=1
-
- MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
---applications ${MonoApplications} --nonstop"
-
- [ -n "$MonoApplicationsConfigDir" ] && \
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---appconfigdir ${MonoApplicationsConfigDir}"
-
- case "$MonoServerChannel" in
- "tcp" )
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---address ${MonoServerAddress} --port ${MonoServerPort}"
- ;;
-
- "unix" )
- [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---filename ${UnixSocketFileName}"
- ;;
-
- * )
- eerror "Please set a valid value for MonoServerChannel"
- return 1
- ;;
- esac
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- modmonoserverpath=1.0/mod-mono-server.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- modmonoserverpath=2.0/mod-mono-server2.exe
- elif [ ${MonoServerVersion} -eq 4 ]; then
- modmonoserverpath=4.0/mod-mono-server4.exe
- else
- eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/mod-mono-server"
- return 1
- fi
-
- export MONO_SHARED_DIR=/tmp
-
- ebegin "Starting mod-mono-server"
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/mod-mono-server.pid \
- --user aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
- -- $MONO_SERVER_OPTS
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping mod-mono-server"
-
- start-stop-daemon --quiet --stop \
- --pidfile /var/run/aspnet/mod-mono-server.pid
-
- eend $?
-}
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server.confd b/dev-dotnet/xsp/files/2.2/mod-mono-server.confd
deleted file mode 100644
index 7cefdbea49b4..000000000000
--- a/dev-dotnet/xsp/files/2.2/mod-mono-server.confd
+++ /dev/null
@@ -1,34 +0,0 @@
-# Config file for /etc/init.d/mod-mono-server
-# $Id: mod-mono-server.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-# Configuration directives for mod-mono-server.exe. For more information on
-# these variables, see the man page for xsp(1).
-
-# This is the document root; trailing slash is not necessary
-#MonoServerRootDir="/usr/lib/xsp/test"
-
-# Directory to search for files with an `.webapp' extension.
-#MonoApplicationsConfigDir="/usr/lib/xsp/test"
-
-# Comma separated list of directories (in the form virtual:real) for all
-# applications managed by the server. For example:
-# /app1:/var/www/localhost/htdocs/app1,/app2:/var/www/localhost/htdocs/app2
-MonoApplications="/mono:/usr/lib/xsp/test"
-
-# The communication channel used between mod-mono-server and mod_mono.
-# unix - A unix socket
-# tcp - A TCP connection
-MonoServerChannel="unix"
-
-# When the comm. channel is "unix", the local filename used by the socket.
-UnixSocketFileName="/tmp/mod_mono_server"
-
-# When the comm. channel is "tcp", IP address for the server to listen on.
-#MonoServerAddress=127.0.0.1
-
-# When the comm. channel is "tcp", port for the server to listen on.
-#MonoServerPort=8080
-
-# If you want to host .NET 2.0 applications you have to set this to 2.
-# Otherwise, leave it unchaged
-MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server.initd b/dev-dotnet/xsp/files/2.2/mod-mono-server.initd
deleted file mode 100644
index 49119e5af497..000000000000
--- a/dev-dotnet/xsp/files/2.2/mod-mono-server.initd
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: mod-mono-server.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-depend() {
- use net
- after dotnet
-}
-
-start() {
- [ -z "$MonoServerRootDir" ] && \
- MonoServerRootDir="/usr/lib/xsp/test"
- [ -z "$MonoApplications" ] && \
- MonoApplications="/mono:/usr/lib/xsp/test,/:."
- [ -z "$UnixSocketFileName" ] && \
- UnixSocketFileName="/tmp/mod_mono_server"
- [ -z "$MonoServerAddress" ] && \
- MonoServerAddress=127.0.0.1
- [ -z "$MonoServerPort" ] && \
- MonoServerPort=8080
- [ -z "$MonoServerVersion" ] && \
- MonoServerVersion=1
-
- MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
---applications ${MonoApplications} --nonstop"
-
- [ -n "$MonoApplicationsConfigDir" ] && \
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---appconfigdir ${MonoApplicationsConfigDir}"
-
- case "$MonoServerChannel" in
- "tcp" )
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---address ${MonoServerAddress} --port ${MonoServerPort}"
- ;;
-
- "unix" )
- [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---filename ${UnixSocketFileName}"
- ;;
-
- * )
- eerror "Please set a valid value for MonoServerChannel"
- return 1
- ;;
- esac
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- modmonoserverpath=1.0/mod-mono-server.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- modmonoserverpath=2.0/mod-mono-server2.exe
- else
- eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
- return 1
- fi
-
- export MONO_SHARED_DIR=/tmp
-
- ebegin "Starting mod-mono-server"
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/mod-mono-server.pid \
- --chuid aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
- -- $MONO_SERVER_OPTS
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping mod-mono-server"
-
- start-stop-daemon -o --quiet --stop \
- --pidfile /var/run/aspnet/mod-mono-server.pid
-
- eend $?
-}
diff --git a/dev-dotnet/xsp/files/2.2/xsp.confd b/dev-dotnet/xsp/files/2.2/xsp.confd
deleted file mode 100644
index 45a79a52bb63..000000000000
--- a/dev-dotnet/xsp/files/2.2/xsp.confd
+++ /dev/null
@@ -1,12 +0,0 @@
-# Config file for /etc/init.d/xsp
-# $Id: xsp.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-# This is the document root; trailing slash is not necessary
-MonoServerRoot=/usr/lib/xsp/test
-
-# Port for the server to run on
-MonoServerPort=8000
-
-# If you want to host .NET 2.0 applications you have to set this to 2.
-# Otherwise, leave it unchanged
-MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/2.2/xsp.initd b/dev-dotnet/xsp/files/2.2/xsp.initd
deleted file mode 100644
index 0432bca7d36e..000000000000
--- a/dev-dotnet/xsp/files/2.2/xsp.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: xsp.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-depend() {
- need net
- after dotnet
-}
-
-start() {
- ebegin "Starting xsp"
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- xsppath=1.0/xsp.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- xsppath=2.0/xsp2.exe
- else
- eerror "MonoServerVersion was not properly set. Check your config file"
- return 1
- fi
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/xsp.pid \
- --chuid aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${xsppath} -- --root ${MonoServerRoot} --port ${MonoServerPort} --nonstop
- eend $?
-}
-
-stop() {
- ebegin "Stopping xsp"
- start-stop-daemon -o --quiet --stop \
- --pidfile /var/run/aspnet/xsp.pid
- eend $?
-}
-
diff --git a/dev-dotnet/xsp/files/aclocal-fix.patch b/dev-dotnet/xsp/files/aclocal-fix.patch
deleted file mode 100644
index 49a00050fe8d..000000000000
--- a/dev-dotnet/xsp/files/aclocal-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile_old.am 2013-07-30 09:11:50.033962122 +0400
-+++ Makefile.am 2013-07-30 09:12:20.843574793 +0400
-@@ -1,10 +1,2 @@
- SUBDIRS=build man src test tools scripts packaging lib
- ACLOCAL_AMFLAGS += -I build/m4
--
--if UNITTESTS
--SUBDIRS += unittests
--endif
--
--if BUILD_DOCS
--SUBDIRS += docs
--endif
diff --git a/dev-dotnet/xsp/files/xsp-2.10.2-endrequest.patch b/dev-dotnet/xsp/files/xsp-2.10.2-endrequest.patch
deleted file mode 100644
index ff702d3faa59..000000000000
--- a/dev-dotnet/xsp/files/xsp-2.10.2-endrequest.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From d2c4a279942a4575b80618719646d0767c077e96 Mon Sep 17 00:00:00 2001
-From: Guillaume Pitel <guillaume.pitel@exensa.com>
-Date: Tue, 6 Mar 2012 17:20:24 +0100
-Subject: [PATCH] Added try/catch around EndRequest Record sending (Bug 3765
- https://bugzilla.xamarin.com/show_bug.cgi?id=3765)
-
----
- src/Mono.WebServer.FastCgi/Connection.cs | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/src/Mono.WebServer.FastCgi/Connection.cs b/src/Mono.WebServer.FastCgi/Connection.cs
-index 6c70824..0e9ef64 100644
---- a/src/Mono.WebServer.FastCgi/Connection.cs
-+++ b/src/Mono.WebServer.FastCgi/Connection.cs
-@@ -319,10 +319,13 @@ public void Run ()
- {
- EndRequestBody body = new EndRequestBody (appStatus,
- protocolStatus);
--
-- if (IsConnected)
-- new Record (1, RecordType.EndRequest, requestID,
-- body.GetData ()).Send (socket);
-+ try {
-+ if (IsConnected)
-+ new Record (1, RecordType.EndRequest, requestID,
-+ body.GetData ()).Send (socket);
-+ } catch (System.Net.Sockets.SocketException) {
-+ }
-+
-
- int index = GetRequestIndex (requestID);
-
---
-1.7.10
-