summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/bitbake/bitbake-9999.ebuild')
-rw-r--r--dev-embedded/bitbake/bitbake-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-embedded/bitbake/bitbake-9999.ebuild b/dev-embedded/bitbake/bitbake-9999.ebuild
index 8f4bcc5b4404..d71043e57f37 100644
--- a/dev-embedded/bitbake/bitbake-9999.ebuild
+++ b/dev-embedded/bitbake/bitbake-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -7,10 +7,9 @@ PYTHON_REQ_USE="sqlite"
inherit distutils-r1 vcs-snapshot
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="git://git.openembedded.org/bitbake.git"
- inherit git-2
- KEYWORDS=""
+ inherit git-r3
else
SRC_URI="https://github.com/openembedded/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86"
@@ -23,8 +22,9 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-RDEPEND="dev-python/ply
- dev-python/progressbar"
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/progressbar[${PYTHON_USEDEP}]"
DEPEND="doc? ( dev-libs/libxslt )"
src_prepare() {