summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild')
-rw-r--r--dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild b/dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild
new file mode 100644
index 000000000000..1b68b8fafadc
--- /dev/null
+++ b/dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A free debugger for use with MSP430 MCUs"
+HOMEPAGE="https://dlbeer.co.nz/mspdebug/ https://github.com/dlbeer/mspdebug"
+SRC_URI="https://github.com/dlbeer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="readline"
+
+DEPEND="readline? ( sys-libs/readline:0= )
+ virtual/libusb:0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i "s:-O1 \(.*\) -ggdb:\1:" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR=/usr/$(get_libdir) $(usex readline "" "WITHOUT_READLINE=1")
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR=/usr/$(get_libdir) PREFIX=/usr install
+ einstalldocs
+}