summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/platformio/platformio-4.0.1.ebuild')
-rw-r--r--dev-embedded/platformio/platformio-4.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/platformio/platformio-4.0.1.ebuild b/dev-embedded/platformio/platformio-4.0.1.ebuild
new file mode 100644
index 000000000000..3062aaa44234
--- /dev/null
+++ b/dev-embedded/platformio/platformio-4.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ <dev-python/click-8[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]"