summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/files/u-boot-tools-2020.01-gcc-10.patch11
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2020.01.ebuild4
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/files/u-boot-tools-2020.01-gcc-10.patch b/dev-embedded/u-boot-tools/files/u-boot-tools-2020.01-gcc-10.patch
new file mode 100644
index 000000000000..321559761517
--- /dev/null
+++ b/dev-embedded/u-boot-tools/files/u-boot-tools-2020.01-gcc-10.patch
@@ -0,0 +1,11 @@
+--- a/scripts/dtc/dtc-lexer.l
++++ b/scripts/dtc/dtc-lexer.l
+@@ -38,7 +38,7 @@ LINECOMMENT "//".*\n
+ #include "srcpos.h"
+ #include "dtc-parser.tab.h"
+
+-YYLTYPE yylloc;
++extern YYLTYPE yylloc;
+ extern bool treesource_error;
+
+ /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2020.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2020.01.ebuild
index 6deafb7f05c9..798ff7a240bc 100644
--- a/dev-embedded/u-boot-tools/u-boot-tools-2020.01.ebuild
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2020.01.ebuild
@@ -20,6 +20,10 @@ DEPEND="
sys-devel/bison
"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
S=${WORKDIR}/${MY_P}
src_compile() {