summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/libnw/libnw-1.30.02.ebuild')
-rw-r--r--dev-games/libnw/libnw-1.30.02.ebuild35
1 files changed, 24 insertions, 11 deletions
diff --git a/dev-games/libnw/libnw-1.30.02.ebuild b/dev-games/libnw/libnw-1.30.02.ebuild
index 7cd617c7c93e..2d64032d35d8 100644
--- a/dev-games/libnw/libnw-1.30.02.ebuild
+++ b/dev-games/libnw/libnw-1.30.02.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Tools and libraries for NWN file manipulation"
@@ -11,21 +12,33 @@ SRC_URI="mirror://sourceforge/openknights/${P}.tar.gz"
LICENSE="openknights"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND="sys-devel/bison
- sys-devel/flex"
RDEPEND="!sci-biology/newick-utils"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog NEWS README README.tech TODO )
src_prepare() {
- sed -i \
- -e '/^CC =/d' \
- -e '/^CXX =/d' \
- $(find . -name Makefile.in) || die
+ default
+
+ local f
+ while IFS="" read -d $'\0' -r f; do
+ einfo "Removing hardcoded CC/CXX from ${f}"
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CXX =/d' \
+ "${f}" || die
+ done < <(find "${S}" -name Makefile.in -type f -print0)
+}
+
+src_configure() {
tc-export CC CXX
+ econf --disable-static
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README README.tech TODO" \
- default
+ default
+ find "${ED}" -name '*.la' -delete || die
}