summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/autodoc/autodoc-2022.10.20.ebuild')
-rw-r--r--dev-gap/autodoc/autodoc-2022.10.20.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-gap/autodoc/autodoc-2022.10.20.ebuild b/dev-gap/autodoc/autodoc-2022.10.20.ebuild
new file mode 100644
index 000000000000..68e237310664
--- /dev/null
+++ b/dev-gap/autodoc/autodoc-2022.10.20.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Generate documentation from GAP source code"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/AutoDoc-${PV}"
+
+# The test suite tries to LoadPackage this
+BDEPEND="test? ( dev-gap/io )"
+gap-pkg_enable_tests
+
+src_prepare() {
+ default
+ rm -f makefile
+}