summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/polymaking/polymaking-0.8.7.ebuild')
-rw-r--r--dev-gap/polymaking/polymaking-0.8.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-gap/polymaking/polymaking-0.8.7.ebuild b/dev-gap/polymaking/polymaking-0.8.7.ebuild
new file mode 100644
index 000000000000..e488b8819e71
--- /dev/null
+++ b/dev-gap/polymaking/polymaking-0.8.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP interface to sci-mathematics/polymake"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests fail: https://github.com/gap-packages/polymaking/issues/18
+RESTRICT=test
+
+RDEPEND="sci-mathematics/polymake"
+
+DOCS=( CHANGES.md README.md )
+
+gap-pkg_enable_tests