summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-crypto')
-rw-r--r--dev-go/go-crypto/Manifest1
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20150808.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-go/go-crypto/Manifest b/dev-go/go-crypto/Manifest
index defc1d2c4e0f..c6220f177ef4 100644
--- a/dev-go/go-crypto/Manifest
+++ b/dev-go/go-crypto/Manifest
@@ -1,3 +1,2 @@
-DIST go-crypto-0_pre20150808.tar.gz 876947 BLAKE2B c6da903ec7b5308114f2e2a364d6a2936dc24be4f8f274116c811740f712f13b2926a6f84b6160c450d921dbbeeb7ce48371e593cfa4d8abf80308f3cf07ac26 SHA512 86826102ff7242259d79a31e543a03192d6b68a06635b46ebac349111bb8451605df1ad9b249c08d75895c38fb4ebbbfc716d40c8c981485395164e87db5a519
DIST go-crypto-0_pre20160126.tar.gz 902001 BLAKE2B 54d38a9aea69e01485417cbf8a900135730dca4bc79c9d5d1187eadb11a8dfca9ef6e72056c4ed4ad4a34b172379d94e6beb82ece9031411b8aa12af85200fb2 SHA512 168129ab9581b7348fb3285e045d99a0a837ac7bd65bf9f5e7a220fffbb9e2abf76da5f521c66eea7179eba0ad8da68d6f41cd9624ea40a9da25a18838427846
DIST go-crypto-0_pre20180816.tar.gz 1637516 BLAKE2B 800787412e1e52f70bc3df5b1b638e86ed2c66de86522786d7e3d8959f18d02426270d1f577ebaa8077d7d98c84ca7a358bed951c862a44b9293de8edebb17b4 SHA512 d2b730ba75b49b96f35969802b7321cd2efc89dcd2e8c0b8eaca545cb18287b34ad1c9ecbd07c6b4ace8708575d4586fbe1139d032a7038cc7221ad010d08074
diff --git a/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild b/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild
deleted file mode 100644
index 32fa7915de5c..000000000000
--- a/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-EGO_PN=golang.org/x/crypto/...
-EGO_SRC=golang.org/x/crypto
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64"
- EGIT_COMMIT="83f1503f771a82af8a31f358eb825e9efb5dae6c"
- SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go supplementary cryptography libraries"
-HOMEPAGE="https://godoc.org/golang.org/x/crypto"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- # disable broken tests
- sed -e 's:TestAgentForward(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
- sed -e 's:TestRunCommandSuccess(:_\0:' \
- -e 's:TestRunCommandStdin(:_\0:' \
- -e 's:TestRunCommandStdinError(:_\0:' \
- -e 's:TestRunCommandWeClosed(:_\0:' \
- -e 's:TestFuncLargeRead(:_\0:' \
- -e 's:TestKeyChange(:_\0:' \
- -e 's:TestValidTerminalMode(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/session_test.go || die
-}
-
-src_compile() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- rm -rf "${T}/goroot/src/${EGO_SRC}" || die
- rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
- export GOROOT="${T}/goroot"
- golang-build_src_compile
-}