summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-md2man/go-md2man-1.0.3.ebuild')
-rw-r--r--dev-go/go-md2man/go-md2man-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-go/go-md2man/go-md2man-1.0.3.ebuild b/dev-go/go-md2man/go-md2man-1.0.3.ebuild
new file mode 100644
index 000000000000..ece084e9d05a
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=github.com/cpuguy83/go-md2man
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A utility to convert markdown to man pages"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/blackfriday"
+RDEPEND=""
+
+src_install() {
+ "${S}"/go-md2man -in src/${EGO_PN}/go-md2man.1.md -out go-md2man.1
+ dobin go-md2man
+ doman go-md2man.1
+}