summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gopls/gopls-0.14.2.ebuild')
-rw-r--r--dev-go/gopls/gopls-0.14.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-go/gopls/gopls-0.14.2.ebuild b/dev-go/gopls/gopls-0.14.2.ebuild
new file mode 100644
index 000000000000..972946ea9171
--- /dev/null
+++ b/dev-go/gopls/gopls-0.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+ARCHIVE_URI="https://github.com/golang/tools/archive/refs/tags/gopls/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="\"Go please\" is the official Go language server"
+HOMEPAGE="https://github.com/golang/tools/blob/master/gopls/README.md"
+SLOT="0"
+LICENSE="BSD"
+BDEPEND=">=dev-lang/go-1.20"
+SRC_URI="
+ ${ARCHIVE_URI}
+ https://github.com/alfredfo/gopls-deps/raw/master/${P}-deps.tar.xz
+"
+# TODO: fix test failure with deps tarball
+RESTRICT+=" test"
+
+S=${WORKDIR}/tools-gopls-v${PV}/${PN}
+
+src_prepare() {
+ default
+ rm internal/regtest/misc/vendor_test.go || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ go test -work "./..." || die
+}
+
+src_install() {
+ dobin gopls
+ dodoc -r doc README.md
+}