summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild')
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild
new file mode 100644
index 000000000000..98c3fd2836cc
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-haskell/prettyprinter-compat-ansi-wl-pprint-1.0.2:=[profile?] <dev-haskell/prettyprinter-compat-ansi-wl-pprint-1.0.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ examples? (
+ dev-haskell/ansi-terminal:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
+ dev-haskell/prettyprinter-ansi-terminal:=[profile?]
+ dev-haskell/text:=[profile?]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}