summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/assoc/assoc-1.1.ebuild')
-rw-r--r--dev-haskell/assoc/assoc-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/assoc/assoc-1.1.ebuild b/dev-haskell/assoc/assoc-1.1.ebuild
new file mode 100644
index 000000000000..da591fd067ca
--- /dev/null
+++ b/dev-haskell/assoc/assoc-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="swap and assoc: Symmetric and Semigroupy Bifunctors"
+HOMEPAGE="https://hackage.haskell.org/package/assoc"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+tagged"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+ tagged? (
+ >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag tagged tagged)
+}