summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild')
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild
new file mode 100644
index 000000000000..40072d8e285b
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}