summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.1.0.0-r1.ebuild')
-rw-r--r--dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.1.0.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.1.0.0-r1.ebuild b/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.1.0.0-r1.ebuild
new file mode 100644
index 000000000000..9b0f0f390a57
--- /dev/null
+++ b/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.1.0.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing of ISO 8601 dates, originally from aeson"
+HOMEPAGE="https://github.com/haskell/aeson"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/attoparsec-0.14.2:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-haskell/base-compat-batteries-0.10.0:=[profile?] <dev-haskell/base-compat-batteries-0.14:=[profile?]
+ >=dev-haskell/time-compat-1.9.4:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3.0.0 )
+ ( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"