summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec')
-rw-r--r--dev-haskell/attoparsec/Manifest3
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild36
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.14.4-r1.ebuild47
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.14.4.ebuild35
-rw-r--r--dev-haskell/attoparsec/metadata.xml8
5 files changed, 86 insertions, 43 deletions
diff --git a/dev-haskell/attoparsec/Manifest b/dev-haskell/attoparsec/Manifest
index d9917fc007b9..878932895f29 100644
--- a/dev-haskell/attoparsec/Manifest
+++ b/dev-haskell/attoparsec/Manifest
@@ -1 +1,2 @@
-DIST attoparsec-0.13.2.3.tar.gz 162346 BLAKE2B 02bcd5d2c4993db547a723fa9f30ddca882a3c13d7c68073e9ed2b093def2f86062b5d9d5c87d9a5ccd13d59ef1b2f962537979320d56444027a1fc931dc98fc SHA512 84805ff547f1aa5eebd320c1bd738bc1098a9789fb330eff7bdcb1b0477e9709d86f93bd8848f4a8501a123b6add6bd22af59cfa94af66f1d57703745706a194
+DIST attoparsec-0.14.4-rev4.cabal 5679 BLAKE2B d03ea52e19bc1e07da35f298245e613040f26d45b63322bc7995566802f71ec9d8aca05d96abc0585e06006053413abe5e58590bcd4fbfe1b13583d8e80788d3 SHA512 b879016ea2ff3ebb7b92d39282d48735d2d063ca94dc7cb6552a4d34607afe778876771911c844bd88cad6065aeb2ab85b7e41bbc8d4f1fe9de205af1a77db56
+DIST attoparsec-0.14.4.tar.gz 160701 BLAKE2B eb7094b0e1b064f5b10c198950b33a085722ee22bd6f0036c8e53aa5475f1b40fe08d528ec3afd547b13cd5712a51e5bcb86a8465a59174a35d603b3f9c13a0a SHA512 48aa7743b24def2db7041e3e0189d9844194c42b5d216ff5060806a80eb550200ddcb11e9321a910ac4881ffdd7381d80a4b88a73acfb29209c650eababb925b
diff --git a/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild b/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild
deleted file mode 100644
index 20e44cf82d48..000000000000
--- a/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.1.9999
-#hackport: flags: -developer
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # Disable test-suite: circular depends
-inherit haskell-cabal
-
-DESCRIPTION="Fast combinator parsing for bytestrings and text"
-HOMEPAGE="https://github.com/bos/attoparsec"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # QC-2.10 finds contradiction
-
-RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
- >=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
- >=dev-haskell/semigroups-0.16.1:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
- >=dev-haskell/text-1.1.1.3:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-developer
-}
diff --git a/dev-haskell/attoparsec/attoparsec-0.14.4-r1.ebuild b/dev-haskell/attoparsec/attoparsec-0.14.4-r1.ebuild
new file mode 100644
index 000000000000..0ea6ec5604e8
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.14.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -developer
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bgamari/attoparsec"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/quickcheck-2.13.2 <dev-haskell/quickcheck-2.15
+ dev-haskell/quickcheck-unicode
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-quickcheck-0.8
+ dev-haskell/vector
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild b/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
new file mode 100644
index 000000000000..d1a1be678f48
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.14.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Disable test-suite: circular depends
+inherit haskell-cabal
+RESTRICT=test # disabled at build time
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bgamari/attoparsec"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.13.2 <dev-haskell/quickcheck-2.15
+# dev-haskell/quickcheck-unicode
+# >=dev-haskell/tasty-0.11
+# >=dev-haskell/tasty-quickcheck-0.8
+# dev-haskell/vector )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/metadata.xml b/dev-haskell/attoparsec/metadata.xml
index c6df28c11857..90b0090fc01f 100644
--- a/dev-haskell/attoparsec/metadata.xml
+++ b/dev-haskell/attoparsec/metadata.xml
@@ -5,12 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A fast parser combinator library, aimed particularly at dealing
- efficiently with network protocols and complicated text/binary
- file formats.
- </longdescription>
<upstream>
- <remote-id type="github">bos/attoparsec</remote-id>
+ <remote-id type="hackage">attoparsec</remote-id>
+ <remote-id type="github">bgamari/attoparsec</remote-id>
</upstream>
</pkgmetadata>