summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/base-orphans/base-orphans-0.9.0.ebuild')
-rw-r--r--dev-haskell/base-orphans/base-orphans-0.9.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild b/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild
new file mode 100644
index 000000000000..b9b1124f43f6
--- /dev/null
+++ b/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Backwards-compatible orphan instances for base"
+HOMEPAGE="https://github.com/haskell-compat/base-orphans#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/quickcheck
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}