summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/base64/base64-0.4.2.4.ebuild')
-rw-r--r--dev-haskell/base64/base64-0.4.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/base64/base64-0.4.2.4.ebuild b/dev-haskell/base64/base64-0.4.2.4.ebuild
new file mode 100644
index 000000000000..064fa0a7d244
--- /dev/null
+++ b/dev-haskell/base64/base64-0.4.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A modern RFC 4648-compliant Base64 library"
+HOMEPAGE="https://github.com/emilypi/base64"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/text-short-0.1:=[profile?] <dev-haskell/text-short-0.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ || ( ( >=dev-haskell/text-1.2 <dev-haskell/text-1.3 )
+ ( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 ) )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/base64-bytestring
+ dev-haskell/quickcheck
+ dev-haskell/random-bytestring
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/text )
+"