summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bifunctors/bifunctors-5.5.15.ebuild')
-rw-r--r--dev-haskell/bifunctors/bifunctors-5.5.15.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/bifunctors/bifunctors-5.5.15.ebuild b/dev-haskell/bifunctors/bifunctors-5.5.15.ebuild
new file mode 100644
index 000000000000..3a05ec6b5ba2
--- /dev/null
+++ b/dev-haskell/bifunctors/bifunctors-5.5.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="The Bifunctors package authored by Edward Kmett"
+HOMEPAGE="https://github.com/ekmett/bifunctors/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+semigroups +tagged"
+
+RDEPEND=">=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/comonad-5.0.7:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/th-abstraction-0.4.2.0:=[profile?] <dev-haskell/th-abstraction-0.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ tagged? ( >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-1.8
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ dev-haskell/transformers-compat )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag semigroups semigroups) \
+ $(cabal_flag tagged tagged)
+}