summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bitwise/bitwise-1.0.0.1.ebuild')
-rw-r--r--dev-haskell/bitwise/bitwise-1.0.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild b/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild
new file mode 100644
index 000000000000..7c437a36a1a8
--- /dev/null
+++ b/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="fast multi-dimensional unboxed bit packed Bool arrays"
+HOMEPAGE="https://code.mathr.co.uk/bitwise"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.12' 'QuickCheck >= 2.4' \
+ 'base >= 4.7 && < 4.12' 'base >= 4.7'
+}