summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/boring/boring-0.2.1.ebuild')
-rw-r--r--dev-haskell/boring/boring-0.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/boring/boring-0.2.1.ebuild b/dev-haskell/boring/boring-0.2.1.ebuild
new file mode 100644
index 000000000000..9f2c10be3afb
--- /dev/null
+++ b/dev-haskell/boring/boring-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Boring and Absurd types"
+HOMEPAGE="https://github.com/phadej/boring"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+tagged"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+ tagged? (
+ >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag tagged tagged)
+}