summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild')
-rw-r--r--dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
new file mode 100644
index 000000000000..6513ce234259
--- /dev/null
+++ b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.1.0.9999
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Chunked HTTP transfer encoding for bytestring builders"
+HOMEPAGE="https://github.com/sjakobi/bsb-http-chunked"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.0.0.4-disable-doctests-ghc-9_2.patch"
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ dev-haskell/attoparsec
+ >=dev-haskell/blaze-builder-0.2.1.4
+ >=dev-haskell/doctest-0.8
+ dev-haskell/hedgehog
+ dev-haskell/tasty
+ dev-haskell/tasty-hedgehog
+ dev-haskell/tasty-hunit
+ )
+"