summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cabal/cabal-2.4.0.1.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-2.4.0.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-haskell/cabal/cabal-2.4.0.1.ebuild b/dev-haskell/cabal/cabal-2.4.0.1.ebuild
deleted file mode 100644
index 0b868d122cef..000000000000
--- a/dev-haskell/cabal/cabal-2.4.0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.6.9999
-#hackport: flags: -bundled-binary-generic
-
-CABAL_FEATURES="lib profile" # Drop test-suite: circular depend
-CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
-inherit haskell-cabal
-
-MY_PN="Cabal"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A framework for packaging Haskell software"
-HOMEPAGE="http://www.haskell.org/cabal/"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-# keep in sync with ghc-8.6
-#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
-
-RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=("${FILESDIR}"/${PN}-2.0.0.2-no-bootstrap.patch)
-
-CABAL_CORE_LIB_GHC_PV="PM:8.6.1 PM:8.6.2 PM:8.6.3 PM:8.6.4 PM:8.6.5"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-bundled-binary-generic
-}