summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cassava/cassava-0.5.2.0-r1.ebuild')
-rw-r--r--dev-haskell/cassava/cassava-0.5.2.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/cassava/cassava-0.5.2.0-r1.ebuild b/dev-haskell/cassava/cassava-0.5.2.0-r1.ebuild
new file mode 100644
index 000000000000..fa7f3d7de5e1
--- /dev/null
+++ b/dev-haskell/cassava/cassava-0.5.2.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="7"
+inherit haskell-cabal
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="A CSV parsing and encoding library"
+HOMEPAGE="https://github.com/hvr/cassava"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/attoparsec-0.11.3.0:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/only-0.1:=[profile?] <dev-haskell/only-0.1.1:=[profile?]
+ >=dev-haskell/scientific-0.3.4.7:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-short-0.1:=[profile?] <dev-haskell/text-short-0.2:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.8:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/quickcheck-instances-0.3.12 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}