summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/chell')
-rw-r--r--dev-haskell/chell/Manifest1
-rw-r--r--dev-haskell/chell/chell-0.4.0.2.ebuild12
-rw-r--r--dev-haskell/chell/chell-0.5.0.2.ebuild44
-rw-r--r--dev-haskell/chell/metadata.xml41
4 files changed, 54 insertions, 44 deletions
diff --git a/dev-haskell/chell/Manifest b/dev-haskell/chell/Manifest
index 5a3a5edcf0be..92abca271534 100644
--- a/dev-haskell/chell/Manifest
+++ b/dev-haskell/chell/Manifest
@@ -1 +1,2 @@
DIST chell-0.4.0.2.tar.gz 12424 BLAKE2B 2e525ecacd0f703a873b89afce7c62937634021e65a54ce901b4b50e535131e1fb831173e4d2b3d52ff351df09eaa386377052b35c7e70c75028b59c87ee21ab SHA512 050c5818ad2cd954ef79b230de2f03fdfb19e99c8624a24bb7845bb20e3b5d5d427a9623491ffc706c5635f545eb99466bde7a851c4344d11df1a70bfb2bbe22
+DIST chell-0.5.0.2.tar.gz 13331 BLAKE2B 3a59f49b5117696290484ece6dad73a3b834a4fdddb62f7ef2f5b27d554a938b47dfc6da616a9d284e15412ca7428aab81371018f559a6c302b1c69e167b3111 SHA512 e2b0cd829882f1c7b18dd2e0ea036b0de27cf859864184ae4b95939d3a5c946e2aa140a49e6596f65326468016de2deb0582428db89893a1b893f25f789c2220
diff --git a/dev-haskell/chell/chell-0.4.0.2.ebuild b/dev-haskell/chell/chell-0.4.0.2.ebuild
index 774e610c9b1d..ca08b3a947e4 100644
--- a/dev-haskell/chell/chell-0.4.0.2.ebuild
+++ b/dev-haskell/chell/chell-0.4.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+color-output"
RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profile?]
@@ -28,11 +28,9 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"
-src_prepare() {
- cabal_chdeps \
- 'ansi-terminal >= 0.5 && < 0.8' 'ansi-terminal >= 0.5'
- default
-}
+CABAL_CHDEPS=(
+ 'ansi-terminal >= 0.5 && < 0.8' 'ansi-terminal >= 0.5'
+)
src_configure() {
haskell-cabal_src_configure \
diff --git a/dev-haskell/chell/chell-0.5.0.2.ebuild b/dev-haskell/chell/chell-0.5.0.2.ebuild
new file mode 100644
index 000000000000..985d88859ab1
--- /dev/null
+++ b/dev-haskell/chell/chell-0.5.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple and intuitive library for automated testing"
+HOMEPAGE="https://github.com/typeclasses/chell"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+color-output"
+
+CABAL_CHDEPS=(
+ 'base ^>= 4.16 || ^>= 4.17 || ^>= 4.18' 'base >= 4.14 && < 5'
+ 'bytestring ^>= 0.11.4 || ^>= 0.12' 'bytestring >= 0.10'
+ 'template-haskell ^>=2.18 || ^>= 2.19 || ^>= 2.20' 'template-haskell >= 2.16'
+ 'text ^>= 1.2.5 || ^>= 2.0' 'text >= 1.2'
+ 'transformers ^>= 0.5.6 || ^>= 0.6' 'transformers >= 0.5.6'
+)
+
+RDEPEND="
+ >=dev-haskell/options-1.2.1:=[profile?] <dev-haskell/options-1.3:=[profile?]
+ >=dev-haskell/patience-0.3:=[profile?] <dev-haskell/patience-0.4:=[profile?]
+ >=dev-haskell/random-1.2.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ color-output? (
+ >=dev-haskell/ansi-terminal-1.0:=[profile?] <dev-haskell/ansi-terminal-1.1:=[profile?]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag color-output color-output)
+}
diff --git a/dev-haskell/chell/metadata.xml b/dev-haskell/chell/metadata.xml
index 321e6543e1d7..231ab15f33f1 100644
--- a/dev-haskell/chell/metadata.xml
+++ b/dev-haskell/chell/metadata.xml
@@ -5,44 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Chell is a simple and intuitive library for automated testing. It natively
- supports assertion-based testing, and can use companion libraries
- such as @chell-quickcheck@ to support more complex testing strategies.
-
- An example test suite, which verifies the behavior of artithmetic operators.
-
- @
- &amp;#x7b;-\# LANGUAGE TemplateHaskell \#-&amp;#x7d;
-
- import Test.Chell
-
- tests_Math :: Suite
- tests_Math = suite \"math\"
- &amp;#x20; test_Addition
- &amp;#x20; test_Subtraction
-
- test_Addition :: Test
- test_Addition = assertions \"addition\" $ do
- &amp;#x20; $expect (equal (2 + 1) 3)
- &amp;#x20; $expect (equal (1 + 2) 3)
-
- test_Subtraction :: Test
- test_Subtraction = assertions \"subtraction\" $ do
- &amp;#x20; $expect (equal (2 - 1) 1)
- &amp;#x20; $expect (equal (1 - 2) (-1))
-
- main :: IO ()
- main = defaultMain [tests_Math]
- @
-
- @
- $ ghc --make chell-example.hs
- $ ./chell-example
- PASS: 2 tests run, 2 tests passed
- @
- </longdescription>
<use>
<flag name="color-output">use colors in program output</flag>
</use>
+ <upstream>
+ <remote-id type="hackage">chell</remote-id>
+ <remote-id type="github">typeclasses/chell</remote-id>
+ </upstream>
</pkgmetadata>