summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/clock/clock-0.8.3.ebuild')
-rw-r--r--dev-haskell/clock/clock-0.8.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/clock/clock-0.8.3.ebuild b/dev-haskell/clock/clock-0.8.3.ebuild
new file mode 100644
index 000000000000..297b45081c79
--- /dev/null
+++ b/dev-haskell/clock/clock-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: -llvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="High-resolution clock functions: monotonic, realtime, cputime"
+HOMEPAGE="https://github.com/corsis/clock"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/tasty-0.10
+ dev-haskell/tasty-quickcheck
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-llvm
+}