summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cmdlib')
-rw-r--r--dev-haskell/cmdlib/Manifest2
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild34
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.6.ebuild35
-rw-r--r--dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch16
-rw-r--r--dev-haskell/cmdlib/metadata.xml31
5 files changed, 0 insertions, 118 deletions
diff --git a/dev-haskell/cmdlib/Manifest b/dev-haskell/cmdlib/Manifest
deleted file mode 100644
index 9655b60371a8..000000000000
--- a/dev-haskell/cmdlib/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST cmdlib-0.3.5.tar.gz 22881 BLAKE2B 867e15e7b32a76f81b01c69ee60af74c8b5752d680693a154e1005167155b2ac501d4c0d1d476295d95c716dbe49f39d2d4f21c1d3f5a64e930adf6c31869289 SHA512 29ca53ddde33d3154b57d56d80eed1e511476ffeb4e4b3722c003770d85d2c4815dccde9d25bc2c86dacad66af6ce6b924c2e97106945a9d9c8ed33fc2424d67
-DIST cmdlib-0.3.6.tar.gz 22971 BLAKE2B 5feb462ee53cf3d5978fdf9b10cec0cabd3522e473e3c06d458a55de1bbc95ce687b4796b974ce9b26b0febd8ef4578093cb498c6bd40bd5dec82bbcfbc446fa SHA512 9d67e931c9caaaaf833215f2561d8ca6aeddd02c64b79343974d0a4d7f1dc618a7af4327ebf50d4071b871b1fd97edc3b5db5bbc8b3334352a20276733602024
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild
deleted file mode 100644
index b93de856c5ca..000000000000
--- a/dev-haskell/cmdlib/cmdlib-0.3.5-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.2.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit base haskell-cabal
-
-DESCRIPTION="a library for command line parsing & online help"
-HOMEPAGE="https://hackage.haskell.org/package/cmdlib"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/mtl-2:=[profile?]
- >=dev-haskell/transformers-0.2.2:=[profile?]
- dev-haskell/split:=[profile?]
- dev-haskell/syb:=[profile?]
- >=dev-lang/ghc-6.10.4:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-PATCHES=("${FILESDIR}/${PN}-0.3.4-ghc-6.12.patch")
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=mtl2 \
- --flag=-test
-}
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild
deleted file mode 100644
index 8d8239c10598..000000000000
--- a/dev-haskell/cmdlib/cmdlib-0.3.6.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.5.9999
-#hackport: flags: -test,+mtl2
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="a library for command line parsing & online help"
-HOMEPAGE="https://hackage.haskell.org/package/cmdlib"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/mtl-2:=[profile?]
- dev-haskell/split:=[profile?]
- dev-haskell/syb:=[profile?]
- >=dev-haskell/transformers-0.2.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=mtl2 \
- --flag=-test
-}
diff --git a/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch b/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
deleted file mode 100644
index 85a19d9aff02..000000000000
--- a/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- cmdlib-0.3.4-orig/System/Console/CmdLib/Command.hs 2011-10-07 07:19:48.000000000 +1100
-+++ cmdlib-0.3.4/System/Console/CmdLib/Command.hs 2012-01-06 20:49:59.668959773 +1100
-@@ -225,6 +225,13 @@
- commandGroup :: (Commands a) => String -> a -> [CommandWrap]
- commandGroup s l = [CommandGroup s (toCommands l)]
-
-+#if !MIN_VERSION_mtl(2,0,0)
-+instance Monad (Either e) where
-+ return = Right
-+ Left l >>= _ = Left l
-+ Right r >>= k = k r
-+#endif
-+
- -- TODO: disambiguation, hidden commands (aliases)
- findCommand :: String -> [CommandWrap] -> [CommandWrap]
- findCommand key list = case accum list of Left x -> [x]
diff --git a/dev-haskell/cmdlib/metadata.xml b/dev-haskell/cmdlib/metadata.xml
deleted file mode 100644
index c97e547df9f1..000000000000
--- a/dev-haskell/cmdlib/metadata.xml
+++ /dev/null
@@ -1,31 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- A commandline parsing library, based on getopt. Comes with a
- powerful attribute system. Supports complex interfaces with many
- options and commands, with option &amp; command grouping, with simple
- and convenient API. Even though quite powerful, it strives to keep
- simple things simple. The library uses "System.Console.GetOpt" as
- its backend.
-
- In comparison to the other commandline handling libraries:
-
- Compared to cmdargs, cmdlib has a pure attribute system and is
- based on GetOpt for help formatting &amp; argument parsing. Cmdlib may
- also be more extendable due to typeclass design, and can use
- user-supplied types for option arguments.
-
- Cmdargs &gt;= 0.4 can optionally use a pure attribute system,
- although this is clearly an add-on and the API is a second-class
- citizen in relation to the impure version.
-
- GetOpt and parseargs both require explicit flag representation, so
- they live a level below cmdlib. GetOpt is in fact used as a
- backend by cmdlib.
- </longdescription>
-</pkgmetadata>