summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/commonmark')
-rw-r--r--dev-haskell/commonmark/Manifest3
-rw-r--r--dev-haskell/commonmark/commonmark-0.2.2.ebuild (renamed from dev-haskell/commonmark/commonmark-0.1.1.4.ebuild)15
-rw-r--r--dev-haskell/commonmark/commonmark-0.2.3.ebuild29
-rw-r--r--dev-haskell/commonmark/metadata.xml4
4 files changed, 42 insertions, 9 deletions
diff --git a/dev-haskell/commonmark/Manifest b/dev-haskell/commonmark/Manifest
index c72f93bc6db1..14827b715c55 100644
--- a/dev-haskell/commonmark/Manifest
+++ b/dev-haskell/commonmark/Manifest
@@ -1 +1,2 @@
-DIST commonmark-0.1.1.4.tar.gz 99102 BLAKE2B 28fd60d2ddb385856ad824cbc73f9f20a35616312e2a4b340e4f0b7fd4311f35155a6fe3d6255a3e2e75a2058627c44119620e0e2caa917e5608cf1284a19641 SHA512 d8f8f652a78d6fcc0b623f6750f3735c22d623a3a8e423384ff0778993c0ac65e986bfb37ba939d0c4cda3db95af2289520883579d82372af5cf5e5bb0540657
+DIST commonmark-0.2.2.tar.gz 101438 BLAKE2B 1e6183e2a9a3d90fb3347bd03779c77314e51d817de7740ae933f328a144a22d729a5dca90f40e1a35967a335d03aaf8e6836b8fe42d12c8d2f52963378c8f6f SHA512 fb1e9d8774c7a2682af8702b94ea4b255ff9dd38fcaba96048d037b3c75051509332ef80631165670a513280e984abf1fa08dd53e85d13f1b4e46941cceadc96
+DIST commonmark-0.2.3.tar.gz 102342 BLAKE2B 1675cb4f995cd76613c9d6fa6ac8f5884a55258b2c76387e286e2cca581946865f3780046332d0dfa9fcb1bf60ca9bd6dce0882ebc7273073261c1104fdd6b9a SHA512 7e3371f6b1aaf4aca3db4ae91894c1e6bd6ea8736babb32de902fba89c2e1f44369bee836fcb1a229948dd72fab25e930bc0cdc143e94d6b136734b9fff3d3df
diff --git a/dev-haskell/commonmark/commonmark-0.1.1.4.ebuild b/dev-haskell/commonmark/commonmark-0.2.2.ebuild
index f6eee2250939..c2186a916523 100644
--- a/dev-haskell/commonmark/commonmark-0.1.1.4.ebuild
+++ b/dev-haskell/commonmark/commonmark-0.2.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.7.9999
+# ebuild generated by hackport 0.7.1.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -14,16 +14,15 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-RDEPEND="dev-haskell/parsec:=[profile?]
- dev-haskell/text:=[profile?]
+RDEPEND=">=dev-haskell/unicode-data-0.3:=[profile?]
+ dev-haskell/unicode-transforms:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
- test? ( dev-haskell/quickcheck
- dev-haskell/tasty
+ test? ( dev-haskell/tasty
dev-haskell/tasty-hunit
dev-haskell/tasty-quickcheck )
"
diff --git a/dev-haskell/commonmark/commonmark-0.2.3.ebuild b/dev-haskell/commonmark/commonmark-0.2.3.ebuild
new file mode 100644
index 000000000000..d83dbe85c596
--- /dev/null
+++ b/dev-haskell/commonmark/commonmark-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure Haskell commonmark parser"
+HOMEPAGE="https://github.com/jgm/commonmark-hs"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/unicode-data-0.3:=[profile?]
+ dev-haskell/unicode-transforms:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
diff --git a/dev-haskell/commonmark/metadata.xml b/dev-haskell/commonmark/metadata.xml
index 937381521944..769758cc2ca3 100644
--- a/dev-haskell/commonmark/metadata.xml
+++ b/dev-haskell/commonmark/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">commonmark</remote-id>
+ <remote-id type="github">jgm/commonmark-hs</remote-id>
+ </upstream>
</pkgmetadata>