summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/conduit/conduit-1.3.4.2.ebuild')
-rw-r--r--dev-haskell/conduit/conduit-1.3.4.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/conduit/conduit-1.3.4.2.ebuild b/dev-haskell/conduit/conduit-1.3.4.2.ebuild
new file mode 100644
index 000000000000..eada6d7aee07
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.3.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/mono-traversable-1.0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.6.3:= <dev-lang/ghc-9.1
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/exceptions-0.6
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/safe
+ dev-haskell/silently
+ >=dev-haskell/split-0.2.0.0
+ >=dev-haskell/unliftio-0.2.4.0 )
+"