summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild')
-rw-r--r--dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild b/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild
index 3ee6c92ef882..9a1918cd2dbc 100644
--- a/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild
+++ b/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# ebuild generated by hackport 0.5.1.9999
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=6
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Fast, pure and practical MD5 implementation"
HOMEPAGE="https://github.com/hvr/cryptohash-md5"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE=""
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-lang/ghc-7.4.1:=
"
@@ -28,11 +28,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/tasty-quickcheck-0.8 )
"
-src_prepare() {
- cabal_chdeps \
- 'base >= 4.5 && < 4.10' 'base >= 4.5' \
- 'tasty == 0.11.*' 'tasty >= 0.11' \
- 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
- 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
- default
-}
+CABAL_CHDEPS=(
+ 'base >= 4.5 && < 4.16' 'base >= 4.5'
+ 'tasty == 0.11.*' 'tasty >= 0.11'
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8'
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+ 'bytestring >= 0.9.2 && < 0.11' 'bytestring >= 0.9.2'
+)