summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptohash/cryptohash-0.11.9.ebuild')
-rw-r--r--dev-haskell/cryptohash/cryptohash-0.11.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash/cryptohash-0.11.9.ebuild b/dev-haskell/cryptohash/cryptohash-0.11.9.ebuild
new file mode 100644
index 000000000000..eced9c7e4297
--- /dev/null
+++ b/dev-haskell/cryptohash/cryptohash-0.11.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="collection of crypto hashes, fast, pure and practical"
+HOMEPAGE="https://github.com/vincenthz/hs-cryptohash"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cryptonite-0.13:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"